PHOTO-REALISTIC FORESTS IN GIMP
A Cartography Guild Tutorial by Arsheesh

Contents

<table>
<thead>
<tr>
<th>Introduction</th>
<th>Page 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forest Outline</td>
<td>Page 2</td>
</tr>
<tr>
<td>Forest Texture</td>
<td>Page 5</td>
</tr>
<tr>
<td>Adding Color</td>
<td>Page 6</td>
</tr>
</tbody>
</table>

How to Use this Tutorial

This tutorial assumes very little working knowledge of GIMP. Throughout the tutorial I will offer explanatory text describing the techniques we are using, followed by highlighted key commands which will look something like the following:

Image > Canvas Size > Lock Aspect Ratio > 100px > Center > Resize

I will also include screenshot figures illustrating some of the tools and settings that we will be using, as well as the progression of the forests. In addition, I’ve also included some “Mapping Tips” windows (just look for the icon) that serve to highlight information I deem important, as well as to offer tips and tricks I’ve learned related to GIMP and fantasy cartography.

What You Will Need

I will be using version 2.6.10 of GIMP for this tutorial. In addition, I will be making use of a custom Script called “Layer Effects” that is not a part of the standard GIMP download package. This script attempts to emulate some of the layer styles available in Photoshop. You can find this script at the GIMP Plug-in Registry. I will also be making use of a custom “Individual Trees” pattern that I made using Feilmage clouds. You can find an uploaded copy of this pattern on the tutorial page where this pdf is posted (I’ve also included a couple of tiled Clouds patterns which you can use, if you should so choose, as an alternative to GIMP’s default Clouds).

INTRODUCTION

This is version 2.0 of a tutorial I created about two years ago. Not long after posting the forests tutorial, its figure faults became evident. The forests produced by people using that tutorial tended to be flat, monochromatic, hard edged shapes that appeared to float above the landscape like giant clouds of broccoli. Over a couple of years I began to improve upon the tutorial in various ways, adding new updates to the thread here and there. Still, I don’t think allot of people read past the first page of the thread because I continued to see a whole bunch of hard edged, limp broccoli forests all over the place. So I decided it was high time to rewrite the tutorial, complete with all the updates that have been made over the last two years.

Forest Outline

For the following demonstration I will be using a cropped section of one of my existing maps. In this section we are going to create the basic shape of our forests.

Creating the Initial Forest Outline

First, let’s create an outline on the map to indicate where the forests will be placed. Grab your “Free Select” tool, and, in the Tool Options Dialogue, change the mode to “Add to the current selection” (which, as the name implies, will allow us to create multiple selections, rather than just one). Now just select the areas of the map where you want to place forests. Try to create a selection that does not cover up geographical areas (such as rivers and mountains) that you want to be visible.
Once you’ve selected all the areas where you want forests, we are going to save this selection to a channel so that we can return to it later. To do this, click on the “Selection” menu and in the drop-down menu click on “Save to Channel”. Now click on your Channels Dialogue. You should see a new channel named “Selection Mask Copy”. Rename this to “Forest Outline 1”. Now return to the “Selection” menu and click on “None”.

Generating Forest Clouds

Now we are going to generate some Clouds which will serve to further give shape to our forests. Create a new white layer and call it “Forests”.

Make sure that your Forests Layer is the active layer. Go to the “Filter” menu and on the dropdown menu click “Render”, and on the subsequent menu click “Clouds” and then “Solid Noise”. In the pop-up menu that emerges, check the “Turbulent” field and set the Detail to 15 and the X and Y size to 16 (alternatively, if you would like to create smaller forest shapes than what is possible given the default Gimp cloud settings, see the “Forests & Map Scale Map Tips below). You should now have a set of clouds that look something like that displayed in Figure 2.

**Toolbox > Free Select > Mode (Add to current selection) > Make selection**

**Select > Save to Channel > Name “Forest Outline 1”**

**Select > None**

**Filter > Render > Clouds > Solid Noise > Turbulent > Detail 15 > Size 16**

**Select > None**

**Player > New Layer > Layer Fill Type (White) > Name “Forests”**

**Filter > Render > Clouds > Solid Noise > Turbulent > Detail 15 > Size 16**

**Select > None**
Next duplicate the “Forests” layer (you can keep the default name of this new layer, “Forests Copy”, the same).

**Layers > Create Duplicate > Name “Forest Copy”**

**Figure 6: Levels**

We are going to adjust the color levels of the Forests Copy Layer, making the output level about a third lighter (NOTE: if you are working with one of the smaller cloud patterns however, skip this step). To do this, go to the “Colors” menu and on “Levels”. In the pop-up menu under “Output Levels” move the left most arrow to 80 (see Figure 6). If you

**Colors > Levels > Output levels > Left Arrow (80)**

**Refining the Forest Outline**

Alright, now we’re going to use the Solid Noise clouds to refine our original Forest Outline. Create a new black layer above the “Forest Copy” layer and name it “Forest Frame”.

**Layers > New Layer > Layer Fill Type (Black) > Name “Forest Frame”**

**Figure 7: Replace Selection with this Channel**

Go to your Channels dialogue and, with the “Forest Outline 1” channel highlighted, click on the “Replace selection with this channel” (see Figure 4). This will restore the earlier selection we made to the image.

**Channels > Forest Outline 1 > Replace selection with this channel**

Click back on your layers dialogue and highlight the “Forest Frame” layer. Fill the selection with white. Turn off the selection.

**Toolbox > Bucket Fill > BG Color Fill (White) > Fill**

**Select > None**

Next change the Layer mode of the “Forest Frame” layer to “Multiply”, which should turn the white sections of the layer transparent, allowing you to see the “Forest Copy” below.

**Layers > Forest Frame > Layer Mode > Multiply**

Go to the “Filters” menu and click on “Blur” and then “Gaussian Blur”. In the pop-up menu that appears change the blur radius to 50. Your image should now look something like Figure 8.

**Filters > Blur > Gaussian Blur > Blur Radius (50)**

**Figure 8: Tree Frame with Gaussian Blur**

Now we are going to apply a threshold to the newly merged “Forest Copy” layer to turn it into a two tone image. This new image will serve as the more refined forest outline. Go to the “Colors” menu and click on “Threshold”. In the pop-up menu that emerges drag the left arrow till you get a set of forest shapes that you like. I’ve found that somewhere between 110-115 is a good number. Now click “OK”. The resulting image should look something like Figure 10.

**Colors > Threshold > Left Arrow > 110-115**

**Figure 9: Threshold**

**Outline Corrections**

At this point it’s a good idea to compare the two-tone outline with your map. An easy way to do this is to hide the “Forests” layer and turn the opacity of the “Forests Copy” layer down to around 35%, so that it is partially transparent. Do any of the white forested areas overlap other geographical features? If so you will want to take a hard round brush and paint black over the offending portions of the white outline (I had to do this here as there were parts of the outline that covered over some rivers).
Now that we have our new forests outline, let’s make a new channel selection from it. Grab the “Select by Color” tool (make sure that the “Threshold” is set to 0), and select anywhere in the white portion of the “Forest Copy” layer.

Now, as before, turn this selection into a channel. Name the channel “Forest Outline 2”.

Isolating the Forests

Now it is time to make our forests. Return to the Layers dialogue and change the layer mode of the “Forests Copy” outline to “Multiply”. Once again, you should be able to see the “Forests” layer below. Next, with the “Forest Outline 2” selection still on, merge the “Forest Copy” layer with the “Forest” layer.

Next go to the “Selection” menu, click on “Invert”, and then hit the “Delete” key on your keyboard. This will remove the black portion of the outline leaving those bare trees exposed. Your image should now look something like Figure 11.

Adding Individual Trees

Next we are going to add some individual trees inside, and around the edges of the forest. Create a new layer just below the Forests layer and name it “Trees”.

In your “Toolbox” select the “Clone” tool. In the tool options, select a small hard round brush (how small may vary based on the size of your map), tick the “Jitter” option and set the “Amount” between 1.00-3.00 (again, this will vary), switch the “Source” from “Image” to “Pattern” and then choose the “Trees Black & White” pattern (one of the custom tutorial patterns). Now use the Clone tool to stamp individual trees on the Trees layer. See Figure 12.
Photorealistic Forests in GIMP – A Cartography Guild Tutorial

By Arsheesh

Yet More Refinement for the Forest Outline

Now that we have individual trees, we need to add their shapes to the Forest Outline 2 channel. To do this, grab the “Select by Color” tool once again (Threshold 0) and, on the “Trees” layer, select the transparent space. You should see the marching ants along each tree. Next, go to “Select” and click “Inverse”.

Add the toolbox > select by color > threshold (0) > select transparent part of layer

Select > Inverse

Now switch to the Channels dialogue and click on the “Forest Outline 2” channel. In your toolbox, grab the “Bucket Fill” tool and fill the selection with white, then go to “Select” and “none”.

Channels > Forest Outline 2 > Toolbox > Bucket Fill > White

Select > None

Forest Texture

Now that we acquired our Forest outline and pattern, it’s time to add some texture to the pattern. An easy way to do this in GIMP is by using the “Noise” and “Bump Map” features.

Adding Noise

Switch back over to the “Layers” dialogue and click on the “Forests” layer. Right click on the “Forests” layer and then click on “Merge Down”. This will merge the Forests & Trees layers.

Layers > Forests > Right Click > Merge Down (onto Trees layer)

Next, on the newly merged “Trees” layer, go to the “Filter”, click on “Noise”, select “HSV Noise” and set “Holdness” to 2, “Hue” to 0, “Saturation” to 0 and “Value” to 30.

Filter > Noise > HSV Noise > Holdness 2; Hue 0; Saturation 0; Value 30

On the newly merged “Trees” layer, go to the “Filter”, click on “Noise”, select “HSV Noise” and set “Holdness” to 2, “Hue” to 0, “Saturation” to 0 and “Value” to 30.

Bump Mapping

Next create a New Transparent layer above the “Trees” layer and name it “Tree Bumps.

Layers > New Layer > Layer Fill Type (Transparent) > Name “Tree Bumps”

Using your Bucket Fill tool, fill this layer with Gray (Value 50%).

Toolbox > Bucket Fill > Gray > Value (50)

Click on the “Tree Bumps” layer and then go to the “Filter” menu, select “Map”, then “Bump Map”. In the pop-up menu that appears, in the “Bump Map” field, select the “Trees” layer and then use the presets shown in Figure 13 below (although if you are using one of the smaller clouds Patterns then you may wish to lessen the Depth of the Bump Map somewhat, otherwise the forests may turn out too bumpy).

Layers > Tree Bumps > Filter > Map > Bump Map (see Figure 13)

Figure 13: Bump Map Settings

Now right click on the “Trees” layer and select “Add Layer Mask”, select on “Channel” and then “Forest Outline 2”. This will result in a set of textured forests like those seen in Figure 14.

Layer > Tree Bumps > Right Click > Layer Mask > Channel > Forest Outline

Figure 14: Textured Grayscale Forests
ADDING COLOR

The last step in this process is to add some color to your forests.

Coloring the Forests

Create a New Transparent Layer above the “Tree Bumps” and name it “Color 1”.

Layers > New Layer > Layer Fill Type (Transparent) > Name “Color 1”

Use your Bucket Fill tool to fill the “Color 1” layer with a dark green color (I’m using color # 1d2300). Set the layer mode of this layer to “Soft Light”. Add the “Forest Outlines 2” layer mask.

Layers > Color 1 > Toolbox > Bucket Fill > HTML # 1d2300

Layers > Color 1 > Layer Mode > Soft Light

Layers > Color 1 > Right Click > Layer Mask > “Forest Outline 2”

Next, create a New Transparent Layer above “Color 1” and name it “Color 2”.

Layers > New Layer > Layer Fill Type (Transparent) > Name “Color 2”

Once again, Use your Bucket Fill tool to fill the “Color 2” layer with a medium green color (I’m using color # 3b580e). Set the layer mode of this layer to “Multiply”. Add the “Forests Outline 2” layer mask to this layer.

Layers > Color 2 > Toolbox > Bucket Fill > HTML # 3b580e

Layers > Color 2 > Layer Mode > Multiply

Layers > Color 2 > Right Click > Layer Mask > “Forest Outline 2”

Now create a New Transparent Layer above “Color 2” and name it, you guessed it, “Color 3”.

Layers > New Layer > Layer Fill Type (Transparent) > Name “Color 3”

Again, Use your Bucket Fill tool to fill the “Color 3” layer with a dark light color (I’m using color # 869f30). Set the layer mode of this layer to “Soft Light”. Add “Forests Outline 2” layer mask.

Layers > Color 3 > Toolbox > Bucket Fill > HTML # 869f30

Layers > Color 3 > Layer Mode > Soft Light

Layers > Color 3 > Right Click > Layer Mask > “Forest Outline 2”

If you are satisfied with the results you could stop here and then proceed to adding a Drop Shadow. However I like to add a little color variety to the forests so that they don’t look so uniform. To do this, Duplicate the Color 3 layer and rename it “Color Variation”. Next, take grab a Medium Small Fuzzy Round Brush from your Toolbox and paint in different colors over the “Color Variations” layer. I’m using a combination of colors, which-in addition to those already mentioned—include a Light Salmon color (# b58f63) and an Ochre color (# d0ca70). However you should experiment around to see what works best for the color pallet of your own map. Once I’ve painted in a variety of different colors on this layer, I blur it somewhat. Go to “Filter”, click “Blur”, then “Gaussian Blur” and set the “Radius” to 25.

Layers > Color 3 > Duplicate Layer > Rename “Color Variation”

Layers > Color Variation > Paint in different varieties of arboreal hues

Filter > Render > Blur > Gaussian Blur > Radius (25)

Adding Forest Shadows

There’s just one final step, adding some shadows to the forests. To do this, click on the “Trees” layer and then go to the “Script Fu” menu (this is not a default menu; it will only appear as a menu option if you’ve installed the “Layer Effects” plugin mentioned in the introduction), click on “Drop Shadow” and then set the “Size” and “Offset Distance” to whatever px you desire. For this example I used the default value of 5 for both, but for a larger regional map I would have lowered it to around 1 or 2. That’s it. You’re finished. The result should look something like Figure 15 below.

Layers > Trees > Script Fu > Drop Shadow > set Size and Offset Distance

Figure 14: Textured Grayscale Forests